Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings
Transfering source/environment settings Transfering source/environment settings
Transfering source/environment settings
Go Back  Xtreme Visual Basic Talk > > > Transfering source/environment settings


Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2006, 01:46 AM
DaveAK DaveAK is offline
Newcomer
 
Join Date: Jun 2006
Posts: 11
Question Transfering source/environment settings


Sorry if this has been covered but I haven't been able to find a solution by searching. Here's my problem. I'm running VB 2005 Express on my old PC and I just purchased a new laptop, downloaded VB, copied all files in My Documents/Visual Studio from my old PC to the new laptop. Opened up my project and went about making revisions. The first revisions I made were to the main form and when I ran it in the IDE all seemed good. Tonight I made changes to a class module within the project but it won't run the changes, instead it runs the original code. When I set a breakpoint to see where it's getting to here's what I get when running :

"The breakpoint will not currently be hit. The source code is different from the original version."

It then goes on to say that I can right click the breakpoint and change the location, or go to Tools|Options|Debugging, neither of which are available in the version I have.

My guess is it's some kind of versioning problem with copying the source from one machine to another, but I have no idea how to fix this. The coding changes I made were relatively simple and I should have been able to have the new program version up and running tonight as foolishly promised. Any suggestions would be gratefully received!
Reply With Quote
  #2  
Old 06-21-2006, 09:25 AM
DaveAK DaveAK is offline
Newcomer
 
Join Date: Jun 2006
Posts: 11
Default

Oh, and in case it makes any difference the old PC ran Windows 2000 and the new one is XP Home. Can't think that it would, but thought I should mention it.

Also when I first started programming in .NET I wasn't getting updated information from my database when running through the IDE. I found some information on how to fix this, but I can't remember what I did or where to find that info. again. This is a similar problem.
Reply With Quote
  #3  
Old 06-21-2006, 09:29 AM
by_m's Avatar
by_m by_m is offline
Contributor
 
Join Date: Jul 2004
Location: Texas
Posts: 661
Default

I'm thinking that this is most likely a problem with your build. Try this:
Go to the menu "Build>Configuration Manager...", and check that the "Active Solution Configuration" is set to "Debug" and that your project is checked to build.
You could also try Cleaning and Rebuilding your solution.
If all else fails though, you should be able to create a new project and add all your source files manually.
Note that I don't have the Express Edition of Visual Basic, so I can't say that you have all these options, but I'd imagine that you would.
__________________
170 10101010 410 J31^170
Reply With Quote
  #4  
Old 06-21-2006, 09:45 AM
DaveAK DaveAK is offline
Newcomer
 
Join Date: Jun 2006
Posts: 11
Default

Thanks by_m but unfortunately I only have Build and Publish under the Build menu in Express. Not sure where Cleaning and Rebuilding are, I can't find them so presume Express doesn't have that option either. If all else fails I'll try the new project approach tonight.
Reply With Quote
  #5  
Old 06-21-2006, 10:46 AM
by_m's Avatar
by_m by_m is offline
Contributor
 
Join Date: Jul 2004
Location: Texas
Posts: 661
Default

That's pretty rough. Is there any chance that you used to be using the beta and now you have the final?
__________________
170 10101010 410 J31^170
Reply With Quote
  #6  
Old 06-21-2006, 07:56 PM
DaveAK DaveAK is offline
Newcomer
 
Join Date: Jun 2006
Posts: 11
Default

Good thought, but I just checked using Help|About and both are identical versions, as is the .NET Framework.
Reply With Quote
  #7  
Old 06-22-2006, 09:05 AM
by_m's Avatar
by_m by_m is offline
Contributor
 
Join Date: Jul 2004
Location: Texas
Posts: 661
Default

I found this on a blog comment (article:http://blogs.msdn.com/danielfe/archi...10/594732.aspx), see if you can use this:
Quote:
Just to be clear, the Clean and Rebuild features are available in Express. From VB Express, select View...Customize...Toolbars... then select the "Build' tab and just drag and drop the "Clean Solution" and "Rebuild Solution" directly back into the Tools toolbar.
If you can't get that, see if you can use this to rebuild your project:
http://msdn.microsoft.com/library/de...neswitches.asp
__________________
170 10101010 410 J31^170
Reply With Quote
  #8  
Old 06-22-2006, 10:12 AM
DaveAK DaveAK is offline
Newcomer
 
Join Date: Jun 2006
Posts: 11
Default

OK, got those added to my Build Toolbar, but Cleaning and Rebuilding didn't fix the problem. Thanks for your help and ideas on this though.
Reply With Quote
  #9  
Old 06-22-2006, 01:37 PM
by_m's Avatar
by_m by_m is offline
Contributor
 
Join Date: Jul 2004
Location: Texas
Posts: 661
Default

Something else of interest, I myself don't have the "Debugging" section under my Tools|Options, to get it I have to check the box in the bottom-left corner saying "show all settings". See if you have that.
__________________
170 10101010 410 J31^170
Reply With Quote
  #10  
Old 06-24-2006, 10:57 PM
DaveAK DaveAK is offline
Newcomer
 
Join Date: Jun 2006
Posts: 11
Default

OK, it turns out that it helps if you register the product. Why part of the program would run fine and not the one module I don't know, but it all seems to be working now that I've registered it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Advertisement:





Free Publications
The ASP.NET 2.0 Anthology
101 Essential Tips, Tricks & Hacks - Free 156 Page Preview. Learn the most practical features and best approaches for ASP.NET.
subscribe
Programmers Heaven C# School Book -Free 338 Page eBook
The Programmers Heaven C# School book covers the .NET framework and the C# language.
subscribe
Build Your Own ASP.NET 3.5 Web Site Using C# & VB, 3rd Edition - Free 219 Page Preview!
This comprehensive step-by-step guide will help get your database-driven ASP.NET web site up and running in no time..
subscribe
Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings Transfering source/environment settings
Transfering source/environment settings
Transfering source/environment settings
 
Transfering source/environment settings
Transfering source/environment settings
 
-->