VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
Go Back  Xtreme Visual Basic Talk > > > VS-2005 app deployment problem when including .NET framework prerequisite


Reply
 
Thread Tools Display Modes
  #1  
Old 06-17-2010, 05:55 PM
mjcatt mjcatt is offline
Newcomer
 
Join Date: Sep 2006
Posts: 12
Default VS-2005 app deployment problem when including .NET framework prerequisite


I'm hoping someone can help with this problem I haven't seen before.

I have a windows app and setup.msi developed in VS-2005/VB SP1+vista enhancements. I want to include the .NET framework prerequisite using the "download prerequisites from the same location as my application". I built the app and setup successfully (running VS as administrator to be safe). Then I ran setup.exe on my Vista machine (same machine used to develop the app), which concluded successfully without errors. I encountered the following 2 problems:

1. The shortcuts to the application (active output) placed on the desktop and start menu don't point to anything so they don't work.

2. Most important, the application does not show up in the windows uninstall a program facility (I had to resort to using a restore point in windows to get rid of it).

I also note that I built the setup NOT using the .NET framework prerequisite everything installed fine (by double-clicking the setup.msi file since setup.exe is not included in this case) - shortcuts work, the app runs and the app shows up in windows uninstall programs and uninstalls without incident.

Of course I should note that the 2.0 .NET framework is obviously already on my system for this test since the system includes VS-2005 therefore the prerequisite is already satisfied for my test (before trying to deploy elsewhere).

I'd appreciate any thoughts on this. Thanks in advance.
Reply With Quote
Reply

Tags
deployment, installer, prerequisite, vs-2005


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Advertisement:





Free Publications
The ASP.NET 2.0 Anthology
101 Essential Tips, Tricks & Hacks - Free 156 Page Preview. Learn the most practical features and best approaches for ASP.NET.
subscribe
Programmers Heaven C# School Book -Free 338 Page eBook
The Programmers Heaven C# School book covers the .NET framework and the C# language.
subscribe
Build Your Own ASP.NET 3.5 Web Site Using C# & VB, 3rd Edition - Free 219 Page Preview!
This comprehensive step-by-step guide will help get your database-driven ASP.NET web site up and running in no time..
subscribe
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
 
VS-2005 app deployment problem when including .NET framework prerequisite
VS-2005 app deployment problem when including .NET framework prerequisite
 
-->