Unspecified Error When Loading Webclass Designer

TrueSystems
08-02-2002, 09:49 AM
Hi there,

Am having a very serious problem with VB6 at the moment.
I can't load webclass designers, when I open a project and double click on the designer I get a pop telling me that I have a "Unspecified Error".

If I try and create a new IIS Application from the Project templates, it returns an error saying
"Errors during load. Refer to webclass.log for details"

When I view that log file all it says is "Line 2: Cannot load control WebClass1."

I've tried uninstalling and reinstalling visual studio, and reapplying service pack 5.

I'm totally stuck!!! Can anyone help me out at all?

Kind Regards

Simon Humphries

True Systems LTD

Thinker
08-02-2002, 12:18 PM
I would start by checking the VB98\Template\Projects folder for
the WebClass.Dsr, WebClass.Dsx, and IIS Application.vbp files.
If they are there, I would search for mswcrun.dll and wbclsdsr.ocx
(should be in Program Files\Common Files\Designer) and make
sure they were registered.

TrueSystems
08-07-2002, 01:30 PM
I did try that, but it didn't seem to work.

I managed to get round the problem by creating a new user on my machine and logging in as that user.

It's something to do with my profile.

Do you know where the VB related stuff is stored in my user profile. I am running windows 2000 SP2.

I would like to clear out all the VB stuff from the profile and reinstall Visual Studio for a "clean" installation.

Again any help is greatly appreceated. :)

Kind Regards

Simon Humphries
True Systems Ltd

Thinker
08-07-2002, 01:54 PM
Maybe the permissions on the install were such that your user
didn't have rights. I don't think there is anything user specific
stored in the profiles (other than possibly in the registry). I would
search msdn.microsoft.com for install issues on win2k (I have
never had problems like this because I always install and use VB
from admin level userids).

TrueSystems
08-08-2002, 06:14 AM
I've solved the problem.

I deleted the temp directory from

C:\Documents and Settings\Administrator\Local Settings

This seemed to have worked.

Thanks again for your help.

Regards

Simon Humphries

True Systems LTD

EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum