2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues
2 weird Ajax issues 2 weird Ajax issues
2 weird Ajax issues
Go Back  Xtreme Visual Basic Talk > > > 2 weird Ajax issues


Reply
 
Thread Tools Display Modes
  #1  
Old 12-05-2007, 04:14 PM
nate's Avatar
nate nate is offline
Junior Contributor
 
Join Date: Mar 2001
Posts: 358
Default 2 weird Ajax issues


I have 2 strange ajax issues I have never had before.

1. When my page loads it displays the modalpopup panel really fast then it goes away. This shouldn't show at all, only when the modal is called.


2. The modal comes up fine and I have a button in the panel. When I click this button the first time it does nothing, so I click it again and it fires. This happens everytime.

Maybe they are related. Thanks in advance.
__________________
Ignorance begins with I.
Reply With Quote
  #2  
Old 12-05-2007, 07:12 PM
Eduardo Lorenzo's Avatar
Eduardo Lorenzo Eduardo Lorenzo is offline
Senior Contributor
 
Join Date: Jun 2006
Location: Manila, Philippines
Posts: 846
Default

Ok. As I understand this is how it goes. Your browser loads stuff this way, HTML, then CSS, then Scripts.

So, since AJAX is script, when the browser loads the HTML, your modal sill be visible until the browser loads the CSS and then fires your Ajax script.

You might be able to work around this by adding a visible = false or something in your CSS so that it won't have to wait until the script fires to become invisible.
__________________
Pinoy ako.. ipinagmamalaki ko.
Reply With Quote
  #3  
Old 12-07-2007, 09:42 PM
nate's Avatar
nate nate is offline
Junior Contributor
 
Join Date: Mar 2001
Posts: 358
Default

Eduardo Lorenzo,
Thanks for the reply. The weird thing is that it only displays the modalpopup panel. I am using 5 popup controls as well on the page and they don't show at all. Then on another page I am using 32 other modalpopups and they don't display, it is only this one. The settings are the same and this is the only time it has ever done this. There must be some setting I am missing. I will look at them more closely. Yes I do need the 32 modal popups I know it sound wierd but it is necessary. I will let you know when I figure it out. Thanks for the heads up I may need to go that route.
__________________
Ignorance begins with I.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Advertisement:





Free Publications
The ASP.NET 2.0 Anthology
101 Essential Tips, Tricks & Hacks - Free 156 Page Preview. Learn the most practical features and best approaches for ASP.NET.
subscribe
Programmers Heaven C# School Book -Free 338 Page eBook
The Programmers Heaven C# School book covers the .NET framework and the C# language.
subscribe
Build Your Own ASP.NET 3.5 Web Site Using C# & VB, 3rd Edition - Free 219 Page Preview!
This comprehensive step-by-step guide will help get your database-driven ASP.NET web site up and running in no time..
subscribe
2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues 2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues 2 weird Ajax issues
2 weird Ajax issues
2 weird Ajax issues
 
2 weird Ajax issues
2 weird Ajax issues
 
-->