=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
Go Back  Xtreme Visual Basic Talk > > > === Strange error.....I already spent a week on this.... need help please


Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2008, 01:35 PM
TampaBay TampaBay is offline
Centurion
 
Join Date: May 2006
Posts: 143
Default === Strange error.....I already spent a week on this.... need help please


I have ASP.NET/VB.NET codes from India. the Indian team coded there and send the codes back to me. The program comes with 1/ the website folder (content index.aspx), 2/ the Datalayer and 3/ the BusinessLayer.

I am using VS.NET 2005 to open it, it can run, but too many strange errors. One of the major error is the breakpoint can't hit.
"The breakpoint will not currently be hit. No symbols have been loaded for this document."
below is a list of all the files that it can't be loaded.

Anyone can help me fix this error? thanks.

http://img510.imageshack.us/my.php?i...orfilesfq5.jpg
Reply With Quote
  #2  
Old 03-24-2008, 01:43 PM
shaul_ahuva=== Strange error.....I already spent a week on this.... need help please shaul_ahuva is offline
Ultimate Contributor

Retired Leader
* Expert *
 
Join Date: Jul 2003
Location: Camp Hill, PA
Posts: 1,992
Default

Does the web.config allow debugging? If not, you can add debug="true" to the system.web/compilation node yourself. You can also just run the site in the debugger (F5) - you'll be asked whether or not you want to allow debugging.

Failing that, is the project set to run/build in Debug or Release mode? Release mode doesn't generate debugging symbols.

Finally, if web.config allows debugging and you're running in Debug mode, it's likely that the project and/or it's references won't build. Try closing ALL designer windows and building the project. If it builds, great! Everything should be fine. If not, then there are some code and/or reference problems that should be showing up in the "Error List" window.
Reply With Quote
  #3  
Old 03-24-2008, 02:12 PM
TampaBay TampaBay is offline
Centurion
 
Join Date: May 2006
Posts: 143
Default

I delete the solution file and start putting the project together again.
1/ Debug already set to "true"
2/ It set to run in debug mode.
3/ When I build the solution, it is fine, but when I run debug, I got this error message, which i don't know what its mean.
"A project with an output type of Class Library cannot be started directly.
In order to debug this project, add an executable project to this solution which references the library project. Set the executable project as the startup project."

I need help with the above error please.... my knowledge is "beginner" thanks.

Last edited by TampaBay; 03-24-2008 at 02:18 PM. Reason: more details
Reply With Quote
  #4  
Old 03-24-2008, 02:18 PM
TampaBay TampaBay is offline
Centurion
 
Join Date: May 2006
Posts: 143
Default

Note for #3/ above. I set the start up project and start up page, then that error is gone.
Now, I still can't debug.
I still get this error "The breakpoint will not currently be hit. No symbols have been loaded for this document."
This error show up at the breakpoint with yellow Exclaimination mark on it instead of solid red dot.

thanks.

Last edited by TampaBay; 03-24-2008 at 02:50 PM. Reason: more details
Reply With Quote
  #5  
Old 03-24-2008, 11:24 PM
Qua's Avatar
Qua=== Strange error.....I already spent a week on this.... need help please Qua is offline
Impetuous & volatile

* Expert *
 
Join Date: Apr 2005
Posts: 2,177
Default

Quote:
Originally Posted by TampaBay View Post
Note for #3/ above. I set the start up project and start up page, then that error is gone.
Now, I still can't debug.
I still get this error "The breakpoint will not currently be hit. No symbols have been loaded for this document."
This error show up at the breakpoint with yellow Exclaimination mark on it instead of solid red dot.

thanks.
In which part of the code are you setting the debug entry point?
Reply With Quote
  #6  
Old 03-25-2008, 09:40 AM
TampaBay TampaBay is offline
Centurion
 
Join Date: May 2006
Posts: 143
Default

<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

<appSettings>
<add key="DSN" value="Server=Dseryuv;Database=TEnpTest;uid=sa;pwd=12345;"/>
<!--<add key="DSN1" value="Data Source=64.27.9.76;Initia;"/>-->
<add key="CrystalImageCleaner-AutoStart" value="true"/>
<add key="CrystalImageCleaner-Sleep" value="60000"/>
<add key="CrystalImageCleaner-Age" value="120000"/>

</appSettings>

<system.web>

<httpRuntime executionTimeout="5000" maxRequestLength="15240" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100"/>
<customErrors mode="Off"/>
<compilation debug="true">
<assemblies>
<add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="Microsoft.JScript, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>
<authentication mode="Windows"/>

<httpHandlers>
<add verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>
</httpHandlers>
</system.web>

</configuration>
Reply With Quote
  #7  
Old 04-04-2008, 05:10 AM
Davearia's Avatar
Davearia Davearia is offline
Junior Contributor
 
Join Date: Jul 2004
Location: In A Perfect Cadence
Posts: 358
Default

The message your getting is strange:
Quote:
"A project with an output type of Class Library cannot be started directly.
A daft question but you have created a web site solution and not a class library soltion instead? If so does it run in release mode?

Cheers, Dave.
__________________
All right, but apart from the sanitation, the medicine, education, wine, public order, irrigation, roads, a fresh water system, and public health, what have the Romans ever done for us?
Reply With Quote
  #8  
Old 04-04-2008, 07:36 AM
shaul_ahuva=== Strange error.....I already spent a week on this.... need help please shaul_ahuva is offline
Ultimate Contributor

Retired Leader
* Expert *
 
Join Date: Jul 2003
Location: Camp Hill, PA
Posts: 1,992
Default

I think the problem is that there are problems with one or more pages. Have you verified that each page builds? I've had situations where the project as a whole would build but one or more pages have errors. Could you by any chance post your solution (without binaries)?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Advertisement:





Free Publications
The ASP.NET 2.0 Anthology
101 Essential Tips, Tricks & Hacks - Free 156 Page Preview. Learn the most practical features and best approaches for ASP.NET.
subscribe
Programmers Heaven C# School Book -Free 338 Page eBook
The Programmers Heaven C# School book covers the .NET framework and the C# language.
subscribe
Build Your Own ASP.NET 3.5 Web Site Using C# & VB, 3rd Edition - Free 219 Page Preview!
This comprehensive step-by-step guide will help get your database-driven ASP.NET web site up and running in no time..
subscribe
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please === Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
 
=== Strange error.....I already spent a week on this.... need help please
=== Strange error.....I already spent a week on this.... need help please
 
-->