Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem
Asp.net Permession problem Asp.net Permession problem
Asp.net Permession problem
Go Back  Xtreme Visual Basic Talk > > > Asp.net Permession problem


Reply
 
Thread Tools Display Modes
  #1  
Old 11-19-2008, 01:00 AM
farazZone farazZone is offline
Freshman
 
Join Date: Jul 2008
Posts: 29
Default Asp.net Permession problem


I am having trouble in viewing images on my asp.net page. I am using IE7 and Firefox 3. I am not able to view the images in browser however standard buttons and text can be viewed. I think there is trouble in the permission but i do not know how to give permission which allow the Images to be viewed.
Reply With Quote
  #2  
Old 11-20-2008, 09:44 PM
Targe Targe is offline
Contributor
 
Join Date: Nov 2006
Posts: 615
Default

Permissions with images? Elaborate on that please.

If you mean visibility due to explicit conditions, just set the image visibility to true/false depending on the If/Then condition in the code behind (aspx.vb) file.

If you cannot access the image control via code behind, make sure the image in the design side (aspx) page has an id specified along with runat="server" in it's tag.
Reply With Quote
  #3  
Old 11-21-2008, 04:28 AM
farazZone farazZone is offline
Freshman
 
Join Date: Jul 2008
Posts: 29
Default

Image visibility is on and Id has been assigned.
I do not Know what is runat="server".
When i tried the website in IE7 i saw the image location but there was a small cross on it.
Reply With Quote
  #4  
Old 11-22-2008, 04:32 PM
Targe Targe is offline
Contributor
 
Join Date: Nov 2006
Posts: 615
Default

Oh don't worry about the runat="server" part unless you need to access it in the code behind for some reason.

The X just means your location is incorrect then. Verify the path of the image by going to it. If you can see the picture at the direct jpg/gif/whatever path and not the page you need to see it in, then I'll need to see some of the code for your image.
Reply With Quote
  #5  
Old 11-23-2008, 06:58 AM
farazZone farazZone is offline
Freshman
 
Join Date: Jul 2008
Posts: 29
Default

I have not use any code and have directly inserted image in a picture box.The images are in the "App_data" Folder. it works in the design view but when i load the page from "localhost" or run The page in Browser the images do not appear.
Reply With Quote
  #6  
Old 11-23-2008, 11:04 AM
Targe Targe is offline
Contributor
 
Join Date: Nov 2006
Posts: 615
Default

Can you provide me with the image code please and the name of your image in the App_data folder?
Reply With Quote
  #7  
Old 11-24-2008, 02:23 AM
farazZone farazZone is offline
Freshman
 
Join Date: Jul 2008
Posts: 29
Default

Name of the image are Info, download and head.
Whats the image code.
Reply With Quote
  #8  
Old 11-24-2008, 02:42 AM
RichardV RichardV is offline
Newcomer
 
Join Date: Nov 2008
Posts: 16
Default

Have you checked the location of the image (during runtime) while rightclicking? The location App_data ain't correct i assume. Normally an imagefolder has to be created in which the images should be placed. The image-location can be made relative by adding a '~' before the path. I don't think it has something to do with permissions except if you mentioned the specific location in you web.config file with certain security settings.....

Regards,

Richard
The Netherlands
Reply With Quote
  #9  
Old 11-24-2008, 07:53 AM
Targe Targe is offline
Contributor
 
Join Date: Nov 2006
Posts: 615
Default

The image code from the aspx file. When you're in design mode, switch to source mode and pull out the section that contains your image code. Like RichardV says, it's most likely just a path problem.
Reply With Quote
  #10  
Old 11-24-2008, 08:38 PM
farazZone farazZone is offline
Freshman
 
Join Date: Jul 2008
Posts: 29
Default

Thanks it worked the image were to be placed in a separate folder not in App_Data folder. Now i can view my images in both web browsers.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Advertisement:





Free Publications
The ASP.NET 2.0 Anthology
101 Essential Tips, Tricks & Hacks - Free 156 Page Preview. Learn the most practical features and best approaches for ASP.NET.
subscribe
Programmers Heaven C# School Book -Free 338 Page eBook
The Programmers Heaven C# School book covers the .NET framework and the C# language.
subscribe
Build Your Own ASP.NET 3.5 Web Site Using C# & VB, 3rd Edition - Free 219 Page Preview!
This comprehensive step-by-step guide will help get your database-driven ASP.NET web site up and running in no time..
subscribe
Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem Asp.net Permession problem
Asp.net Permession problem
Asp.net Permession problem
 
Asp.net Permession problem
Asp.net Permession problem
 
-->