Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Go Back  Xtreme Visual Basic Talk > > > Trouble publishing and deploying an aspx webpage to an existing website


Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2010, 12:58 PM
garethmann garethmann is offline
Centurion
 
Join Date: Jul 2003
Location: Fort Lauderdale, Florida
Posts: 105
Default Trouble publishing and deploying an aspx webpage to an existing website


I have just started using Visual Studio.NET, before I would build all my sites in Dreamweaver using VbScript.

I have been following the tutorials of how to build an ASP.Net website in Visual Studio.NET. I have compiled the website and it runs fine on my local machine. However, when I try to ftp the directory including all the files of the website to a subdirectory of an existing website on a remote host, I get the following error:

Code:
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.
Here is where the page is located:

http://www.northmiamicra.org/testnet/default.aspx

Is this something to do with the fact that my local machine thinks that the webpage is the actual homepage of new website, but on the actual hosted site, it is simply an additional page in a subdirectory of an existing website?
__________________
"Any sufficiently advanced technology is indistinguishable from magic."
Arthur C. Clarke
Reply With Quote
  #2  
Old 03-30-2010, 01:40 PM
garethmann garethmann is offline
Centurion
 
Join Date: Jul 2003
Location: Fort Lauderdale, Florida
Posts: 105
Default

I appear to have solved the problem. I had to create a virtual directory of that subdirectory on the remote host.
__________________
"Any sufficiently advanced technology is indistinguishable from magic."
Arthur C. Clarke
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Advertisement:





Free Publications
The ASP.NET 2.0 Anthology
101 Essential Tips, Tricks & Hacks - Free 156 Page Preview. Learn the most practical features and best approaches for ASP.NET.
subscribe
Programmers Heaven C# School Book -Free 338 Page eBook
The Programmers Heaven C# School book covers the .NET framework and the C# language.
subscribe
Build Your Own ASP.NET 3.5 Web Site Using C# & VB, 3rd Edition - Free 219 Page Preview!
This comprehensive step-by-step guide will help get your database-driven ASP.NET web site up and running in no time..
subscribe
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
 
Trouble publishing and deploying an aspx webpage to an existing website
Trouble publishing and deploying an aspx webpage to an existing website
 
-->